On Fri, Oct 09, 2020 at 07:13:49PM +0800, Wu Fengguang wrote:
- private def set_kernel
- self["kernel"] = "kernel #{vmlinuz()}"
- end
That's counter intuitive. job.kernel should be the kernel, not some initrd string.
The kernel can download and select an executable image, then pass the kernel params to the image for boot.
Should I split the download and select? use initrd to download then use kernel to select?
Or change the name to kernel_uri?
btw, the kvm.sh will wget the kernel file when run the kernel line.
Thanks, Xueliang
- self["initrds"] = temp_initrds.join(" ")
Why not use Array?
Thanks, Fengguang