On Tue, Nov 03, 2020 at 03:07:30PM +0800, Zhang Yuhang wrote:
On Tue, Nov 03, 2020 at 02:49:42PM +0800, Lu Weitao wrote:
+# dimensions: +# eg: [ +# {'os' => 'openeuler', 'os_version' => '20.03'}, +# {'os' => 'centos', 'os_version' => '7.6'} +# ] +# metrics: +# eg: ['fio.read_iops', 'fio_write_iops'] +# return: group_matrix of Hash(String, Hash(String, matrix)) +def combine_group_query_data(query_data, groups_params, dimensions, metrics)
- job_list = query_data['hits']['hits']
- groups = auto_group_by_template(job_list, groups_params, dimensions, metrics)
The function name, "auto_group_by_template", I feel so wired, which sound like will do something, then return true/false.
actually, we can do like this,
reference: todo/doc/the-art-of-readable-code.md
## 用具体的名字代替抽象的名字
在给变量、函数或者其他元素命名时,要把它描述的更具体而不是更抽象。
### 例1
ServerCanStart() => 直接描述这个方法要做什么事情: CanListenOnPort()
Thanks, Weitao
Thanks, Zhang Yuhang