On Fri, Feb 05, 2021 at 05:39:22PM +0800, Weihang Li wrote:
As usual, this series collects some miscellaneous fixes and cleanups at the end of 5.12 for the hns driver:
- #1 ~ #3 fix some non-urgent issues.
- #4 ~ #6 make some changes on existing features.
- #7 ~ #12 are cleanups, just do some refactor and delete dead code.
This series is made based on the series named "RDMA/hns: Several fixes and cleanups of RQ/SRQ" which is still being reviewed: https://patchwork.kernel.org/project/linux-rdma/cover/1611997090-48820-1-git...
I'm worried that it will be too late for 5.12 if any patch of this series needs changes, so I send it before the previous one is merged. If there is any comment or merge conflict on it, I will fix them as soon as possible, thanks.
Lang Cheng (3): RDMA/hns: Replace wmb&__raw_writeq with writeq
This one is quite a good idea
RDMA/hns: Move HIP06 related definitions into hns_roce_hw_v1.h RDMA/hns: Avoid unnecessary memset on WQEs in post_send
Lijun Ou (1): RDMA/hns: Disable RQ inline by default
Weihang Li (2): RDMA/hns: Avoid filling sgid index when modifying QP to RTR RDMA/hns: Fix type of sq_signal_bits
Xi Wang (1): RDMA/hns: Add mapped page count checking for MTR
Xinhao Liu (2): RDMA/hns: Remove some magic numbers RDMA/hns: Delete redundant judgment when preparing descriptors
Yixian Liu (1): RDMA/hns: Remove unnecessary wrap around for EQ's consumer index
Yixing Liu (2): RDMA/hns: Skip qp_flow_control_init() for HIP09
RDMA/hns: Adjust definition of FRMR fields
I didn't apply this one because of my question, but did take the rest to for-next, thanks
Jason